Firefox 40.0.2 Flash bug

Firefox Latest Version May Break Flash Player Plugin

Updated 30 Sep, 2016

Firefox version 40.0.x has already received more than a few reports about breaking Flash player plugin compatibility. However not all is lost, here’s what you can do.

In case you’ve experienced some problems playing Flash media in Firefox lately, it may encourage you to know that you’re not alone.

Some users have already reported all sorts of issues revolved around Flash player, mainly the fact that it doesn’t work or doesn’t work properly for the very least.

As an avid Firefox user myself I’ve experienced some of these issues as well and upon further investigating I found that Firefox itself is the culprit.

Version 40.0.2 to be more specific, although meant as a bug-fixing release for the latest stable Firefox 40 line has actually introduced a new bug instead of just fixing existing ones.

Nevertheless, since much of the web technology efforts in past few years have gone into HTML 5 capability to serve as a suitable replacement for Adobe’s Flash player, some of you perhaps didn’t even notice the new bug.

To see whether you are indeed suffering from the new Flash player plugin bug, visit the following web address – Flash test  and see whether the test runs for you.

In case you can’t make the particles (see image below) move, or you don’t see them at all, then you probably are affected by the new Flash bug.

Flash player plugin particles test

So what can you do in case you are affected by the bug?

Quick Solution

Now that you’re aware of what causes the Flash player problems and that you’re indeed having them, the solution would probably be already obvious to you – simply downgrade Firefox to an older version.

Download old Firefox version

Furthermore, in case you’re a Linux user who loves using Firefox, you may also want to look into changing the Flash plugin to a different one which supports new Flash versions as depicted here and here.

Note that prior to downloading and installing anything from the web, it is first advised to check whether it’s available on the package repository provided by the Linux distribution you currently am using.

The comment section is temporarily closed due to remodeling.