Youtube Setup

Youtube Setup

Provider:Twilight0
Type:program
Version:2.1.0
Views:97
Help other people decide, vote up or down?
Youtube Setup fanart

Youtube Setup program addon

Disclaimer

This addon is provided "as is". Please read LICENCE for more details.

Description

This addon will help you setup Youtube api keys.

News

+ 2.1.0 ~ (07-08-2020)- Add support for paste.osmc.tv- Added hindi support (contrib: spyderboy92)- Added swedish support (contrib: Sopor)- Clean up+ 2.0.2 ~ (22-04-2020)- Minor tweak for yesno dialog (for Kodi 19)+ 2.0.1 ~ (22-04-2020)- Added the following translations: > German: thanks to horstle > Spanish: thanks to roliverosc+ 2.0.0 ~ (06-04-2020)- Proper Python 3 support- Added support for hastebin.com- Simplified setup function- Removed "youtube.api.enable" setting for post 6.7.0 youtube addon versions- Added support for google's client.json file from the credentials screen > If api_key is not found in the json file, youtube setup will ask to be entered manually > You can enter it in the file prior to the setup just by adding an additional key, see client.json example- Added the following translations: > Romanian: thanks to tmihai20 > Dutch: thanks to dagwieers > Russian: thanks to vlmaksime- Bug fixes

View More

How To Install

Direct installation

Via Repository

Via Directory

  1. Download the addon.
  2. Open up Kodi and navigate into Add-ons.
    addon install - Add-ons
  3. Click the open box icon (above the side-menu).
    addon install - openbox
  4. Select Install from zip file.
    • If this is the first addon you install, Kodi will warn you about installing addons from "unknown sources" for security reasons - it's your call.
    • In any case, Kodi will warn you, you may not get auto-updates for this addon.
  5. Navigate into the location where you've downloaded the addon to and select it to Install.

    For a full installation guide please click here.

    Additional Information

    Updated: March 29, 2021

    Platform: all

    Alternative Sources:

    License: GNU GPL, version 2

    Depends On:

    xbmc.python (>= 2.24.0)

    YouTube (>= 6.8.3)

    Tulip Library (>= 2.6.11)

    Recommended Addons