InputStream Helper

InputStream Helper

Type:script
Version:0.5.7+matrix.1
Views:2038
Help other people decide, vote up or down?

Kodi InputStream and DRM playback made easy

Description

A simple Kodi module that makes life easier for add-on developers relying on InputStream based add-ons and DRM playback.

News

v0.5.7 (2021-07-02)- Further improve Widevine CDM installation on ARM hardwarev0.5.6 (2021-06-24)- Improve Widevine CDM installation on ARM hardware- Postpone Widevine CDM updates when user rejectsv0.5.5 (2021-06-02)- Improve Widevine CDM installation on ARM hardwarev0.5.4 (2021-05-27)- Fix Widevine CDM installation on ARM hardwarev0.5.3 (2021-05-10)- Temporary fix for Widevine CDM installation on ARM hardware- Fix Widevine CDM installation on 32-bit Linuxv0.5.2 (2020-12-13)- Update Chrome OS ARM hardware id'sv0.5.1 (2020-10-02)- Fix incorrect ARM HWIDs: PHASER and PHASER360- Added Hebrew translations- Updated Dutch, Japanese and Korean translationsv0.5.0 (2020-06-25)- Extract Widevine CDM directly from Chrome OS, minimizing disk space usage and eliminating the need for root access- Improve progress dialog while extracting Widevine CDM on ARM devices- Support resuming interrupted downloads on unreliable internet connections- Reshape InputStream Helper information dialog- Updated Dutch, English, French, German, Greek, Hungarian, Romanian, Russian, Spanish and Swedish translations

View More

How To Install

Direct installation

Via Repository

  1. Download the addon.
  2. Open up Kodi and navigate into Add-ons.
    addon install - Add-ons
  3. Click the open box icon (above the side-menu).
    addon install - openbox
  4. Select Install from zip file.
    • If this is the first addon you install, Kodi will warn you about installing addons from "unknown sources" for security reasons - it's your call.
    • In any case, Kodi will warn you, you may not get auto-updates for this addon.
  5. Navigate into the location where you've downloaded the addon to and select it to Install.

For a full installation guide please click here.

Additional Information

Updated: January 13, 2021

In Repositories:

Platform: all

License: MIT

Depends On:

xbmc.python (>= 2.25.0)

PySocks (>= 1.6.8)

Recommended Addons